OpenID between gitea.gna.org and hosteadashboard broken

For hosteadashboard:

  • :white_check_mark: substitute in the website
  • :white_check_mark: The mail of the admin user needs to be updated manually
  • Resetting oidc may not work because it is in use (see here) … and it won’t work either because of the domain name change

image

(eǝ) debian@gitea-host:~$ cat /srv/hosteadashboard/oidc.delete.log
2022/09/05 03:45:08 main.go:117:main() [F] Failed to run app with [/usr/local/bin/gitea admin auth delete --id 15]: login source is still used by some users [id: 15]

@realaravinth do you have a suggestion on how to handle this elegantly?

@realaravinth I believe this is the last thing that requires fixing. I’ll take care of it if you can’t.

I think I fixed it, please verify and let me know if the issue still exists!

Changes

  1. Update redirection URL of the Gna Gitea on the hosteadashboard admin. Used to have point to the Hostea Gitea. When relying party provided redirection URL doesn’t match the configured, OIDC will fail. Updating the URL fixed it.

  2. Update the URL of the hosteadashboard to use hosteadashboard.gna.org on the Gna Gitea

My dashboard account is linked to my Gitea account, I tried logging in with the dashboard SSO after making the changes and it seems to work.

1 Like

I’m logged in the dashboard:

image

Clicked on New Support and successfully logged in via OpenID

image

It’s nice that fixing the URL can be done manually from the admin panel, good find :+1:

1 Like